MySQL 4.0、5.0、5.1 の共存インストール

  MySQL 4.0インストール済み環境に、MysQL 5.0、MySQL 5.1 を共存



それぞれのバージョンでメリットがある為、2006/07/20 現在では全て共存する方向で考えます。

MySQL 4.0 : sjis 完全対応、レンタルサーバなどはまだこのバージョン
MySQL 5.0 : sjis は、テーブル名に使えない(バグ) が、正式リリース版
MySQL 5.1 : sjis 完全対応、但しベータ版でインストーラが付属していない


  • ※ MySQL 5.0 : ODBC ドライバが最新でないと動きません。5.1 は 古いタイプの 3.51 ドライバが動作します
  • ※ MySQL 5.1 : 06/09/08 現在で、4.0 で動いていたある複雑なSQL がエラーになりました。
  • ※ MySQL 5.1 : 06/09/11 追記 : group by の処理で ODBC ドライバは最新でないと動きませんでした
  • ※ MySQL 5.1 : 06/09/14 追記 : Shift_JIS で作成したDBが接続時 set names 'sjis' をしないと化ける環境がありました











  infoboard   管理者用   
このエントリーをはてなブックマークに追加




SQLの窓  天気  IT用語辞典
Yahoo!ニュース  マルチ辞書
PHP マニュアル  Google URL短縮 


フリーフォントWEBサービス
SQLの窓WEBサービス

SQLの窓フリーソフト

素材

一般WEBツールリンク

SQLの窓

フリーソフト

JSライブラリ