MySQL 4.0、5.0、5.1 の共存インストール


  PHP での実行



MySQL 4.0 と MySQL 5.1 は、PHP 4 のいままでの環境でそのまま動きました。

しかし、MySQL 5.0 は、PHP で実行すると、以下のエラーが出ます

Client does not support authentication protocol requested by server; consider upgrading MySQL client

未確認ですが、これを動かすには PHP 5 の MySQL 改良版拡張サポート(mysqli) が必要そうですが、
なにかと環境設定が面倒そうです。

結局 ベータですが、MySQL 5.1 が全てにおいて使いやすいという事が解りました。
この結果から、MySQL 5.1 はひょっとして古い ODBC ドライバも使えるのでは無いかと思います。
( 使えました、というか深いところで最新版よりちゃんと動きます )

MySQL 4.0 で出ていた sjis.conf が無いとエラーになるという問題も発生しません。
( MySQL 5.0以降 では、xml になっています )










  infoboard   管理者用   
このエントリーをはてなブックマークに追加




SQLの窓  天気  IT用語辞典
Yahoo!ニュース  マルチ辞書
PHP マニュアル  Google URL短縮 


フリーフォントWEBサービス
SQLの窓WEBサービス

SQLの窓フリーソフト

素材

一般WEBツールリンク

SQLの窓

フリーソフト

JSライブラリ